Page 1 of 1

Having some trouble getting a MIDI controller to work

Posted: Wed Oct 28, 2020 7:12 am
by jyn
Image

Hello, I've built my own prototype MIDI controller out of a Teensy 4.0 and two 10k potentiometers. The code I'm running (https://github.com/joshnishikawa/MIDIcontroller) works for another software that allows MIDI controllers, Cecilia. The two pots do control the sliders in that software.

In SunVox, I can't get it to work. It clearly sees the instrument and a green box appears when I turn the two dials, but it doesn't register to a controller. Here's a video of what I see:

https://youtu.be/RclT95j_sA0

If there's anything specific I'm missing please let me know. I'm very new to MIDI controllers, I have a manufactured keyboard that works well in Sunvox but that's it.

edit: Note, I am new to MIDI controllers but not new to programming arduino. If there's anything I can do to make the MIDI instrument more robust such that Sunvox would recognize it, I can probably manage. But I don't know what might be missing.

Re: Having some trouble getting a MIDI controller to work

Posted: Thu Oct 29, 2020 9:55 am
by NightRadio
Are you sure your device is sending commands on MIDI channel 2?
Please try to set it to "ANY"

Re: Having some trouble getting a MIDI controller to work

Posted: Thu Oct 29, 2020 8:52 pm
by jyn
It works! Any works, but I also verified the channel with another software and it is apparently going through channel 5. That seems pretty arbitrary - I'll have to dig into the code and figure out how to set that. And also read up on MIDI events in general and learn how they work. Thank you!