Bug when using both audio and midi in delay block

Found a bug? Post it here.
Post Reply
philipbergwerf
Posts: 89
Joined: Sat Mar 17, 2018 4:23 pm

Bug when using both audio and midi in delay block

Post by philipbergwerf » Mon Oct 05, 2020 5:04 pm

I found a bug which happens if you use this configuration:

Code: Select all

meta1IN > multisynth > generator > meta1OUT > meta2IN > delay > generator > meta2OUT
                                                          |__________________^
In this configuration meta1 keeps playing on midi input when it's not selected. Maybe it's something small but since both audio and midi at the same time is a great future I hope this can be fixed. It behaves weird ;) There is no midi connection between meta1 and meta2 and still both synths are playing.
Attachments
little Bug.sunvox
(5.84 KiB) Downloaded 22 times

User avatar
AutumnCheney
Posts: 198
Joined: Sun Dec 29, 2019 8:16 am
Location: durant, ok, usa
Contact:

Re: Bug when using both audio and midi in delay block

Post by AutumnCheney » Mon Oct 05, 2020 5:26 pm

i've noticed this too. a workaround is to route a multisynth to meta2 and play it, then only meta2 plays
please check out my newgrounds account, i post music and talk to people here: https://autumncheney.newgrounds.com

i have a soundcloud and bandcamp too (just music here):
https://soundcloud.com/autumncheney
https://autumncheney.bandcamp.com

User avatar
NightRadio
Site Admin
Posts: 3469
Joined: Fri Jan 23, 2004 12:28 am
Location: Ekaterinburg. Russia
Contact:

Re: Bug when using both audio and midi in delay block

Post by NightRadio » Wed Oct 07, 2020 2:55 pm

It's a feature of MetaModule :)
It automatically detects whether it can accept notes from the keyboard or not.
Delay confuses him - it thinks that Delay is just an effect without input port for the notes.
I will add two additional options to MetaModule:
"Receive notes from the keyboard" and "Don't receive notes from the keyboard"

There are two workarounds:
1) use additional multisynth, as AutumnCheney noted;
2) set "Play patterns" to nonzero value;

Post Reply