MetaModule sometimes does not produce sound when custom controllers are changed by Sound2Ctl/MultiCtl

Found a bug? Post it here.
Post Reply
User avatar
AutumnCheney
Posts: 55
Joined: Sun Dec 29, 2019 8:16 am
Contact:

MetaModule sometimes does not produce sound when custom controllers are changed by Sound2Ctl/MultiCtl

Post by AutumnCheney » Mon Apr 27, 2020 10:43 am

This is one of two threads detailing bugs relating to the functionality of the MetaModule when a module controller is being changed by an internal Sound2Ctl or MultiCtl in real time. I have found both of these bugs in the versions of SunVox for Linux X64 and Android 7.

When, inside of a MetaModule, a module controller linked to a custom MetaModule controller is being changed in real time by a Sound2Ctl or MultiCtl, the MetaModule, which is set to normally produce sound when it receives note events, sometimes inexplicably does not produce sound. I don't know why this occurs, and it appears to happen randomly. I don't think that it has anything to do with CPU or RAM resources, as I have seen it on my laptop with relarively high specs.

I have provided a small project file that demonstrates this bug. However, as this is bug may be based on chance, you may not see it immediately.
Attachments
2020-04-27 00-07.sunvox
(3.64 KiB) Downloaded 8 times
please check out my newgrounds account, i post music and talk to people here: https://autumncheney.newgrounds.com

i have a soundcloud and bandcamp too (just music here):
https://soundcloud.com/autumncheney
https://autumncheney.bandcamp.com

Post Reply