empty spectrum from MultiSynth connected to two Generators

Found a bug? Post it here.
Post Reply
Pavel
Posts: 6
Joined: Fri Mar 20, 2020 2:12 am

empty spectrum from MultiSynth connected to two Generators

Post by Pavel » Fri Mar 20, 2020 2:24 am

To reproduce the problem it's enough to play a note on the Analog Generator module and then play a note on the MultiSynth module in the project shown in the following screenshot. Although there is an audio signal and the output module also shows it, the spectrum screen remains blank. The project file is in the attachments to this post. I use windows_x86_64/sunvox.exe version 1.9.5d.
no_spectrum.png
no_spectrum.png (48.75 KiB) Viewed 255 times
Attachments
test_1.sunvox
(5.53 KiB) Downloaded 7 times

User avatar
queries
Posts: 262
Joined: Tue May 10, 2016 9:51 pm

Re: empty spectrum from MultiSynth connected to two Generators

Post by queries » Fri Mar 20, 2020 3:57 am

The spectrum analyzer only analyzes the currently selected module. To see a combined analysis of two modules, connect them to an Amplifier and select that module. To see the analysis of the master output, same thing, just have Output selected.

Pavel
Posts: 6
Joined: Fri Mar 20, 2020 2:12 am

Re: empty spectrum from MultiSynth connected to two Generators

Post by Pavel » Fri Mar 20, 2020 4:20 am

What I observe is that sometimes the spectrum is displayed and sometimes not.

If I select Generator2 in my project, then play a note, then I select MultiSynth3 and play a note, the spectrum is shown.

If I select Analog Generator, then play a note, then I select MultiSynth3 and play a note, the spectrum isn't shown.

User avatar
NightRadio
Site Admin
Posts: 3302
Joined: Fri Jan 23, 2004 12:28 am
Location: Ekaterinburg. Russia
Contact:

Re: empty spectrum from MultiSynth connected to two Generators

Post by NightRadio » Sat Mar 21, 2020 12:16 pm

I will check it, thanks!

Post Reply