MIDI note on/off problem on channels other than 1

Multi-platform modular music creation studio
Post Reply
justin
Posts: 17
Joined: Thu Jan 14, 2016 9:01 pm

MIDI note on/off problem on channels other than 1

Post by justin » Thu Feb 01, 2018 2:21 pm

Hi, I am having problems sending (Linux JACK) MIDI messages to Sunvox on any channel other than 1.

I have a very simple Sunvox file, just an Analog Generator connected to Output. I set Analog Generator -> Module Properties -> MIDI In -> 'Always / Channel 1' - I can then hear the Analog Generator play a note when I send some MIDI note on / off messages down channel 1. But if I repeat the process using channel 2 (resetting Analog Generator -> Module Properties -> MIDI In) I can no longer hear any notes.

:-(

I am pretty sure I am sending the MIDI message down the correct channels each time - I connected QMidiRoute up and can see the different channels to which messages are being sent (see below).

Am I missing some vital step here ? Any thought on how to debug effectively ?

Thanks :)

------------------------

QMidiRoute Event Log

09:04:02.334 Ch 1, Note On 50, Vel 127
09:04:03.336 Ch 1, Note Off 50
09:04:12.847 Ch 2, Note On 50, Vel 127
09:04:13.847 Ch 2, Note Off 50
09:04:20.195 Ch 1, Note On 50, Vel 127
09:04:21.195 Ch 1, Note Off 50
09:04:24.230 Ch 2, Note On 50, Vel 127
09:04:25.229 Ch 2, Note Off 50

User avatar
queries
Posts: 192
Joined: Tue May 10, 2016 9:51 pm

Re: MIDI note on/off problem on channels other than 1

Post by queries » Thu Feb 01, 2018 5:58 pm

In SunVox main menu -> preferences -> MIDI section, check to make sure you have "any" channel selected next to the device name.

justin
Posts: 17
Joined: Thu Jan 14, 2016 9:01 pm

Re: MIDI note on/off problem on channels other than 1

Post by justin » Thu Feb 01, 2018 6:23 pm

отлично! Thank you very much!

Post Reply