Sound2Ctl not responding to R channel [FIXED in 1.9.4b]

Found a bug? Post it here.
Post Reply
User avatar
Saltbearer
Posts: 72
Joined: Thu Sep 04, 2014 2:18 am
Location: Caflirinoa
Contact:

Sound2Ctl not responding to R channel [FIXED in 1.9.4b]

Post by Saltbearer » Mon Jul 30, 2018 2:31 pm

I'm rounding up a couple old metamodules for the 1.9.5 module submission thread. I thought Slack Panner could be a decent candidate, buuut it looks like Sound2Ctl might be bugged?

The module used signals to Sound2Ctls on both the L and R channels to control panning delay. Sound2Ctls don't seem to be responding to any R signals right now.

Here's a shrunken-and-shrunken-again-to-attachment-sized piece of the old abandoned project it was made for:
theresalwayssomeone bugged snippet.sunvox
(60.63 KiB) Downloaded 73 times
It seems like there are *flickers* of R channel activity, but I can't really tell.

Here's what that sounds like now, except compressed to death, but only the rhythm really matters. Wow these files need to be small:
tas snip.mp3
(59.6 KiB) Downloaded 62 times
0:20 here is what it used to sound like, so I know it was able to receive the R-channel signals to switch sides at the appropriate times back around 1.9.1

The manual says "Input port of the Sound2Ctl is for receiving the audio signal. Output port of the Sound2Ctl is for transmitting the commands like “set controller X to the value Y”." Is the R channel the command transmission port? Has it always been that way? Or is that something else entirely?

User avatar
NightRadio
Site Admin
Posts: 3025
Joined: Fri Jan 23, 2004 12:28 am
Location: Ekaterinburg. Russia
Contact:

Re: Sound2Ctl not responding to R channel

Post by NightRadio » Mon Jul 30, 2018 10:24 pm

You are right, thanks!
This is a bug in SunVox 1.9.4. Will be fixed in 1.9.4b very soon

Post Reply